DXZeff's Computing Forum
DXZeff's Computing Forum
Search | Statistics | User Listing Discord | Forums | Language
You are logged in as a guest. ( logon | register )

Compaq Contura 4/25 notebook doings..
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   Computer Speak -> General ComputingMessage format
 
GlitchHiker
Posted 2019-05-08 9:58 PM (#1604)
Subject: Compaq Contura 4/25 notebook doings..


Harris 286

Posts: 20
0
Hi gang,

Well it started off with just wanting to DOS around, see episodes I, II, III down the page here...

http://forum.dxzeff.com/forums/thread-view.asp?tid=13&start=1101

(Didn't figure how to link particular posts, it's page 45 on default 25 posts per page)

It started to turn into more of a project than just some playing around, so thought I would keep the rest here in one thread and quit spamming the P/B/M with it. It's in general because I guess I might end up elbows deep in either hardware or software ends of things.

The machine: Compaq Contura 4/25 486SL notebook, mono screen,
The mission: collect underpants, ???, profit... IDK get a booting DOS installed drive in there with nice selection of games and stuff, maybe WFWG 3.11, chill and enjoy.

So on to, Episode IV: A New Hope...

I spent this morning collecting up "useful shit" for the attack. Spare 2.5 drives, 200MB, 800MB, 1G, 2G, 2.5"-3.5" adapter, CF to 2.5" adapter, PCMCIA IDE card to 2.5", 128MB, 512MB, 4GB Compact flash cards, CF to USB, I found a parallel cable that looked suspiciously like a laplink cable, though not old faithful, seems to have right pins connected by multimeter. Also turned up a couple of DB9 plugs with solder buckets so if parallel don't work, guess I'll make a serial null modem out of cat5 or something. Found linksys prism based wifi "b" card that should work with XP/E500 or 98/380XD... also got crossover cable and 3com PCMCIA NIC, USB drives, USB floppy...

So, turned up this article (Other interesting vintage stuff on site) http://www.toughdev.com/content/2011/09/compaq-contura-325c-80386-l...
Which is for same series but 386 model, it looks very similar in setup etc. Now, I don't really see that I'll benefit from tracking down the point and click setup. So wondering if I wanna screw with drive overlays, and the odd thing is, that there's some larger than 512MB drives in the drive table which made me think it has some level of LBA support. In my previous experience, I have usually found that you can set the drive type with IDE to more or less anything close and the drive goes "whatever" and pretends it understands. One of three things happens with no large drive support, no drive seen at all, drive seen but can't be read past 512MB, drive seen but translation doesn't work and there's read errors up the wazoo. None of these are happening, everything seems to work perfectly after booting from floppy, apart from the missing operating system message. Maybe however, it is not seeing the top of the partition right, I suspect I may have formatted the drive on another machine way back sometime. I am wondering if it will boot if I bring the partition size inside 512MB. If I mess with overlays I've gotta reformat the dang thing and put everything back on it, and I can't do that the quick way by sticking it in another box, or using the PCMCIA IDE interface.

I noticed I had some HDD speed tools on there, I think I remember being disappointed with the drive speed when I put it in. It's getting about 1500kb/sec from a drive that should do 5000. So wondering if it's worth "wasting" the CF-IDE and one of the flash cards in it, since it seems that the interface sucks. So I guess if I'm stuck with using overlay for anything big and it's gonna be slow anyway, I should stick the 2G 2.5 in it if I want the room.

Now I found a 200MB drive, with a compaq sticker on it, hey, was this it's original??? Maybe, but why did I remove the sucker? Guess I just wanted bigger. And realising I've downloaded over a gigabyte of stuff, zipped that I just wanna try out, I guess 200MB is not gonna be very satisfactory.... But... maybe I should stick it in first to see if it all boots up fine and dandy and see what the score is.

So, got a plan B, C, D, E, F, G, H.... in that lot so will get cracking again this evening and see what I can do...
Top of the page Bottom of the page
GlitchHiker
Posted 2019-05-09 3:05 AM (#1605 - in reply to #1604)
Subject: Re: Compaq Contura 4/25 notebook doings..


Harris 286

Posts: 20
0
Hokay, just lots of messing around to fully characterise the problem. And refreshing my memory about 1024 cyl barrier etc. which i don't think is it, type 41 has 1631 cyl, type 62 1696 and that's just the bigger ones, think couple of the smaller ones go over that too. Anyway, yesterday I tried ALL the drive types over 500MB and they ALL showed "missing operating system" however on reviewing drive specs from Toshiba, i decided most compatible should be type 42, so changed to that, and it schroedingbugged me, now I know that type is rightest it got past missing operating system, did a brief read, and threw up "invalid system disk" instead... ah, just needs mbr or sys doing, do both, reboot and no error, it hits the disk twice and just hangs on flashing cursor, oh you bar-steward... Not sure if this drive would actually work now if I deleted the partition, repartitioned, reformat etc etc... but wanna back dis shit up first... and it gets me 500MB instead of 650 or whatevs... I'm probably gonna want the 2G in it... wait, unless the old toshiba P133 something or other CDT only has a gig, that has sound and is bursting at seams could use clean up really, but I was kinda holding onto old software installs in case they came in useful, you know the kind of thing.

It's starting to worry me a bit that none of the diags have picked up the parallel port yet... it may be powered down when unused or something, forgot all what SL chipset does... haven't even had the "probably a laplink cable" on it, so done nothing to kill it.

Soooo next move seeing if the 200MB boots right. Still suspicious of it's behaviour,
Top of the page Bottom of the page
DXZeff
Posted 2019-05-09 4:36 AM (#1606 - in reply to #1605)
Subject: Re: Compaq Contura 4/25 notebook doings..



Pentium II

Posts: 453
1001001001002525
Location: Hull, UK
There are a couple of portable systems here that I'll never fix solely because they need floppy disks to be set up and I refuse to use those. Even without that, getting these things to work is often a chore because you can't just hook things up in ways that are kinda 'cheating' as you would with a desktop.
Top of the page Bottom of the page
GlitchHiker
Posted 2019-05-09 5:58 PM (#1607 - in reply to #1604)
Subject: Re: Compaq Contura 4/25 notebook doings..


Harris 286

Posts: 20
0
Indeed, it wasn't even so bad back in the day when you had a stack of 20 or so reliable DOS/Win disks, get it fresh installed in an afternoon. Even modern systems you're often more than a day rebooting for all the damn updates. However, getting it all from scratch with limited reliable floppy media on hand is a huge pain. Once upon a time I had MS original media, probably have to go through a dozen or two boxes to find it, and who knows what shape it's in when I find it, and whether aging floppy drive mechanisms will kill it right quick. Funny thing, I'm not really ALL about portables, you're stuck with config you get mostly, but it was your Toshiba that brought me here by a circuitous route. Somewhere I have a 386SX16 version, doornail dead HDD, it also only had 2MB RAM, anyway, buried that one deep somewhere because of perceived uselessness, slow for 386, low RAM, no hdd. But then when it's at the back of my mind to have a machine with a nice keyboard for playing old text adventures, I catch a random mention somewhere that Toshiba 3xxx series only like connor drives and started googling. I figure that when it turns up again I can marry it up with at least a 40MB Connor now I know the trick. Won't need much on that one. Presuming I don't get to like the keyboard on the Contura here, feels a bit like work at the moment, just needs a bit more pushing like they're keycaps on top of chicklet. The stiffness is okay for button mashers, but I like something I can forget about for "leisure typing" as it were.

Annnd yeah, thought I had a cheat mode worked out, newest system with a PCMCIA slot and built in wifi and more than one USB, so I could use PCMCIA IDE adapter dump stuff on a 2.5 but win7 didn't like it. The XP/E500 or 98/380XD I'll have to keep swapping wifi and IDE adapter in and out, gah. and their single USBs are in awkward places to swap flash drives over, don't got much desk space for long tangles of USB hubs and extra PSU for usb/ide ... think I'm just gonna have to get going a slower way with 380XD and plod through it.
Top of the page Bottom of the page
GlitchHiker
Posted 2019-05-10 5:11 PM (#1608 - in reply to #1604)
Subject: Re: Compaq Contura 4/25 notebook doings..


Harris 286

Posts: 20
0
This whole thing is going like https://youtu.be/AbSehcT19u0

Most of yesterday I was hunting wifi cards/sticks and drivers, all the ones I could find a CD for, (With win98 driver) I can't find the card, all the cards I find, no CD .. and damn hard to find win98 drivers online now. Kept getting sidetracked digging down old FTP file trees etc. So finally get a driver, now how to get it on the 98/380XD okay I'll use a USB stick, but a small one I guess because can't be ExtFAT or NTFS and 4GB file limit. So dig around for oldest smallest USB sticks and 98/380XD likes precisely none of them, won't work with default USB storage drivers.. bastard. Okay, so I need to burn them on CD... great.. no CD-Rs to be easily found, where the fuck are they now??... did turn up a single CD-RW, might give that a go later. ... also started eyeballing a dell axim PDA, thinking, you know what, if I can download to SD card and stick it in that, I might be able to "beam" it by IR ports... that's when I realised that this dependency chain is getting super crazy.

But finally last night a victory, I had also been searching drivers for the Apricorn EzGig PCMCIA IDE card, with no success, it was kinda not marketed as hardware but as a macguffin for their EZGig drive mirroring system, which swiftly became based on USB<>IDE adapters instead... however, found some old docs, with no mentions of driver installs being needed and an old distributor page saying it could no way be upgraded to use on XP... yeah it barfed on win7 and the XP machines here, so with no drivers I'd given up on it... until I got to one of those "What the hell" points last night and tried it on the 98/380XD and YES!!! it uses standard IDE controller drivers on windows 98, finally some luck... So just got as far as going through the loose 2GB 2.5" drive, checking for stuff I wanna back up. So that drive is clear for re-use. Gotta check the others later. Might have to use that with the CF<>IDE to transfer the damn drivers. This all might be going a bit quicker if I could have more than 2 machines set up at once, but tight for space so juggling them all round. Ideal would be to have one of those long folding tables set up in the middle of a room and I could get good and dizzy running circles around it, heh.

Player 10 enters the game... I swear I'm up to 10 machines messed with at least in this quest so far... this one isn't essential to it, just wanted to check this morning how much drive space it had, remembered it being tight and I wanted to make sure I didn't commit a drive I might need for it. So, pulled out the Toshiba Satellite Pro 440CDT... holyfuckingshitballs the hard drive is dead on this douchenozzle too. Not totes mcgotes, it seeks but not recognised. Damn. I am pondering the possibility that I took an EMP hit when lightning struck across the street last year, about 60ft away. None of these were plugged in or operating. Just wondering if they got EEPROMs or Flash ROMs screwed up from it. Everything that died so far was in the same corner of the house nearest the hit. Anyway, probably had the default 1.4GB in there, which I might not have thought worth the hassle of changing out for the 2GB, if you know, it worked. I think the 2GB would be not really worth it for the Armada 1750 if that turns out to need it, or depending how dead it is, the 1580 might end up donating it's 4GB, but I'm probably going to try getting a 20GB in that, or maybe look out for one. So 440CDT wasn't gonna be that useful for now, I have the CD drive in it and floppy did not come with it.

Alrighty, mostly gonna be messing with the 380XD today I guess, cleaning off 2.5" drives and getting drivers on it, to get it reading re-usable media other than floppies or networked, or both.
Top of the page Bottom of the page
DXZeff
Posted 2019-05-10 5:15 PM (#1609 - in reply to #1607)
Subject: Re: Compaq Contura 4/25 notebook doings..



Pentium II

Posts: 453
1001001001002525
Location: Hull, UK
I still have original DOS and Windows disks, but they don't work any more and I don't believe many of the drives around here work either. Laptops are worse because when their drives go bad you have to seek out a specific model to replace them, which is often difficult if not impossible, or else very expensive - from what I remember, the SlimsPORT's drive cost nearly as much as the laptop is probably worth.

You can probably use drive overlay software to install a different hard drive, though you may have to F1 your way past an error message, ANYDRIVE works for the T3200SX so it might just work for other models too, but it is limited to 512M drives. You can use it with larger drives or flash cards, the max parameter should be noted in the README so just use those and ignore the rest of a larger drive if you're really stuck I guess. Problem is, you need a floppy to install ANYDRIVE, then you have to restart and fiddle with the Shift key to boot the DOS install disk - obviously because the DDO needs to be loaded before manipulating the drive in any way, in this case installing DOS or Windows.

On the up side, if you have a Win98 system running then, audio codec permitting, you should be able to run loads of stuff on there anyway.
Top of the page Bottom of the page
GlitchHiker
Posted 2019-05-10 9:26 PM (#1610 - in reply to #1609)
Subject: Re: Compaq Contura 4/25 notebook doings..


Harris 286

Posts: 20
0
Yes, I think I recall mine were getting bad sectors 15+ years ago, I wasn't daft enough to think they'd improved. Heh, yeah I just saw some stupid pricing for a drive for that 440CDT, floppy drive was $225 on sale for only $199 LOL I'll take three. Meanwhile a battery or a screen was only $25, used to be the screen was the $1000 part.

I'll try and remember the ANYDRIVE tip for when the T3XXX turns up thanks, might be months off though, think it's 3 stacks deep at back of storage. Probably using it on the 4/25 though. I'd maybe settle for playing on the 98/380XD but for there being a distracting screen fault, bright line on the right, the power jack being twitchy, the hinge being loose and the "clit mouse" rubber being all rotten and crumbling, it's not a museum specimen exactly.

---------------------------------- ----------------------------------- --------------------------------

So far today, freaking typical... tested the CDRW disk in 98/380XD read fine, nothing I needed on it, so stick it into win7 sys to burn drivers to it, and that drive can't even see it never mind write it, wtfbbq. Have one singe CD-R blank I could find, swear there's two cake boxes half full of the damn things around somewhere, but they've crept into a shady corner or something, can't consciously recall storing them in a particular place. Anyway, one single blank, better burn at low speed to make sure of it... and it coasters, bad burn, damn damn damn. Then I found a couple of CD-Rs with practically nothing on them, but sessions were closed, gah.... Though I see that 98 not meant to like multisesh, but OTOH it read that CDRW which I thought was... oddness... if I get really desperate will see if the discount store nearby still has singles and buy a couple.

But, recap on where I'm at, still trying to enable some mass input of data on win98 machine so I can use it to prep disks and download by laplink to 4/25... or to cut a link out of the chain get it networked so not having to pass through from a win7 or newer machine...

So, just found USB mass storage drivers that fit on a floppy, the win 98 wifi drivers are 8MB+ so can't put those on a floppy. Messing with USB floppy on win 7 again, getting bad sectors one disks I try writing, is it the USB or the crappy disks I'm trying to recycle?? Gah.... guess I'm going to have to break down and open fresh pack of disks... but for this even if win 7 does mess up doing boot sectors I just to get some data over to the win98 machne that's (touch wood) booting independantly.

Crap, what am I on now, plan N ?

Edit: sweet at least the new floppies are getting read/written okay in the USB floppy, I should think so too, I was gonna get serious about Memorex's "lifetime warranty" if I had to... you know what this retro kick is getting too uncomfortably actually like pre-1994 computing when all floppy disks are precious and you're worried about $200+ drives lol.

Edited by GlitchHiker 2019-05-10 9:45 PM
Top of the page Bottom of the page
GlitchHiker
Posted 2019-05-11 1:59 AM (#1611 - in reply to #1604)
Subject: Re: Compaq Contura 4/25 notebook doings..


Harris 286

Posts: 20
0
3 steps forward 2 steps back...

USB mass storage drivers from here worked .. http://www.technical-assistance.co.uk/kb/win98se-usb-mass-storage-d... copying to a dos data disk with IBM USB floppy on Win7/32bit worked.
yay, can read a USB stick...

wifi drivers... the damn linksys installer appeared to work, but there's only NT 4.0 and XP drivers on there, damn you Cnet download you bunch of liars, saying they had win98 drivers... damn you linksys too for not supporting your products.... kudos to Toshiba who have notebook drivers for everything they ever made (apparently) and HDD tech specs etc. (It's a wifi B card, fairly sure most of them had 98 drivers until Vista came out, G cards I can forgive)

So gotta go hunting again for actual win98 drivers I guess. I can probably get them for a sweet old Compaq card I have, prism based, but the problem with that sucker is, I need it for frigging everything, old PDAs, Puppy linux live CDs, Amiga 1200, all of them want that fucker and I've only got one of them.

Finally found box of CD-Rs, right after the USB drive started working, I swear my stash of DVD-Rs multiplied just to troll me, I thought I only had 2 boxes, found 4, each time it was "that one MUST be CDs.." Still, I might need them if I have to block the 380XD's USB hole with a USB Wifi... though actually shouldn't need it with wifi going...

Maybe won't put toooo much more effort into getting wifi going, will just have to use 3 machine sneakernet, now I can get stuff into 380XD. Though getting stuff out might become issue... only a gig available on drive and might have several gigs of recoveries to do with the 440CDT and Armadas...

Yeah, thinking I'm gonna sort of production line things when we get going, while I a) remember what I'm doing, b) the 380XD still works, c) the boot floppies I'll make don't have bit rot, d) while all the random shit like the PCMCIA IDE adapter and laplink cable are all together. I get a feeling I might need to use a working armada to CPR the 380XD in the future, maybe need to tag team between the 3 of them as long as I can find HDDs LOL or convert them all to compact flash.

Edit: RE floppy drives for laptops, what I managed to do ONCE, but you gotta get a bit lucky is I had a removable IBM unit from a thinkpad I didn't own that I found was the identical mechanism to one in an Acer travelmate that was going bad, the interface plugs were custom so, had to build the two of them into one, faceplate swap etc, was not straightforward. Also managed similar a couple of times with optical drives.


Edited by GlitchHiker 2019-05-11 2:22 AM
Top of the page Bottom of the page
GlitchHiker
Posted 2019-05-12 6:53 PM (#1612 - in reply to #1604)
Subject: Re: Compaq Contura 4/25 notebook doings..


Harris 286

Posts: 20
0
The latest round of idiocy..

So I'm not sure if all my spare 2.5" drives are dead apart from the 2GB or just the apricorn PCMCIA interface doesn't like them. I was not too surprised/dismayed that the compaq 200MB didn't work, since that must have been why it came out of the 4/25 in the first place. I could have sworn that the 1GB was working 2 or 3 years ago when I spun it up on a USB/IDE adapter though. It's looking like I will be just trying to back up the drive that's in the 4/25 then setting it up with anydrive or similar and reformatting.

Then I spent way too much time messing with linksys and compaq wifi "B" cards in the 98/380XD. Although I called the compaq a "sweet" card because it's close to prism reference design so 3rd party drivers on other OS and architectures work great, the win98 official compaq driver works, but their wifi utility really sucks, doesn't let you know what's going on at all. So anyway, dicked around with that and it wasn't connecting to the "retro router" older Dlink b/g deallie. So went looking for the linksys drivers again and found latest, strangely labeled for V4 of the card but supporting earlier versions according to release notes. Anyhoo, get that installed and card is recognised exactly how it wasn't with the package that was missing the 98 driver. Then that card was not connecting either to router.. but was something weird about it. So I try getting on the router with an older android and it's apparently bouncing new connections, top one, smashing, great, router is fucky, probably could have saved hours if I figured that out sooner. So probably compaq and linksys card are working just fine. This router used to do this when it was in daily driver use years ago when it got too hot, had more than 7 or 8 machines connect and had been running more than a week. Resetting it and cooling it down used to work, but it hasn't been warm and it's was freshly started with only a couple of machines on it, so didn't even think it was gonna misbehave. Anyway, getting another older router found and set up is just one side quest too many for now.

Did find a 2GB stick that works on 380XD so that's better than the 128MB which was "safest" to get working initially. In view of the fact that I seem to have far less CD-Rs than anticipated, I was happy to grab half a pack of CDRW at a yard sale yesterday, they're a different color than the other one the win7 machine didn't like before, so hope these ones work.

Then the last stupid, which is actually my stupid rather than the damn hardware, I got a load of stuff downloaded and copied to the 380XD by USB stick and realised that it was mostly 7zip compressed with the .7z format, gah, either gotta go back to different machine and repack it or find 7zip for 98. Their site only says they are x86 32bit windows binaries, so IDK what that means exactly until I try them.... I wonder if they work on a no-fpu 386sx with WFWG 3.11 with -Win32s LOL

edit: Guess this looks like the 7zip version to use for 98 here.. http://dk.toastednet.org/vogons/win98/

Edited by GlitchHiker 2019-05-12 8:12 PM
Top of the page Bottom of the page
GlitchHiker
Posted 2019-05-13 12:10 AM (#1613 - in reply to #1604)
Subject: Re: Compaq Contura 4/25 notebook doings..


Harris 286

Posts: 20
0
Okay, guess the win7/IBM USB floppy drive combo isn't to be trusted after all, munched up a new disk. Seems that you can manage to write a file or two to pre-formatted disks but formatting and writing images is unreliable.

Hooked up the laplink cable... fired up laplink on the contura 4/25 and the 380XD ... everything looks great at the 380XD end, but contura end, port is still in stealth mode, can't get it to recognise, failing self tests on all IRQ and address combinations.. run diags again, nothing sees it... reboot into CMOS setup change port settings to LPT 3 irq 5 in case 7 has issue or something, same thing, can't see shit. reboot, reset CMOS defaults (Though I did that just a couple of days ago, and the battery is holding settings, think I changed it a few years back) and went back into LL5 and wow, it connected, but still fails self test. So dunno what's going on with it, exactly what was wrong and why it started working, probably forced it to work by sheer willpower, or it heard me thinking about pulling out the soldering iron. So got what's on there backed up, hopefully it will work again to get stuff back again.


Edit: Heh, even though that version of 7zip works on win98, it really was a stupid not pre-processing the 7zip files on a modern system, it's a stream format to take advantage of using single dictionary for all files for higher compression, meaning they're all in one glob, you know what that means, yah, just to read the readmes or other text files you need to process the whole damn lump, which if it's a big file is very slow on a vintage machine with only a couple of hundred mhz .




Edited by GlitchHiker 2019-05-13 2:33 AM
Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete all cookies set by this site)
Running MegaBBS ASP Forum Software
© 2002-2019 PD9 Software